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1.0 Introduction 

This quick start guide is intended to give new users the ability to be able to use some of the 
basic functions within Maximus®. No prior knowledge of Maximus is required.  
This guide will demonstrate how to set up a simple steady-state network, import a Multiflash® 
fluid, run the model and extract results.   
 
The general workflow for building a model in Maximus is described below in Figure 1: 

 

 

Figure 1: General Workflow for Maximus 
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2.0 The Maximus Interface  

 

Figure 2: Maximus main GUI 

When Maximus is opened, the window shown in Figure 1 will be visible. This is the new 
default view (Ribbon) for version 7.6. The main areas in the window are as follows:  

A. This is the model canvas where the pipe network is constructed using objects from 

the objects bar.  

B. This is the model tree which lists objects and functions within the model.   

C. This is the dynamic solution messages panel where messages and errors are 

displayed in real time during simulation runs.  

D. This is the object toolbar where the tabs can be selected for  

a. File 

b. Home  

c. Insert (objects) 

d. View  

e. Reports 

f. Tools 

g. Information (about the current version) and Help button 

E. This is the ribbon that will change according to the tab selected simulation toolbar 

where the following options are available:  

a. Access other Maximus windows  

b. Control the model including start, pause, restart, and stop simulation.  

F. This is the mini map where the whole network is shown to the user and where the 

model canvas is zoomed into. This can be used to navigate the model canvas easily 

by dragging the black rectangle.  
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G. This is the status bar showing the current statuses of the model and the progress of 

any simulation runs.  

 

The object and simulation toolbars can be configured to have a ribbon bar view (default) or 

the original Classis view instead of the above. To change to the classic view, use the Switch 

to Classis option under View and the view will change to:  

 

 

Figure 3: Maximus classic view 

To switch from Classic to Ribbon view then, under Setup>General select the GUI settings 

tab and select “show ribbon bar”.  

 

Note: Some screenshots may differ slightly in their appearance to the version that you are 

using. 

3.0 Setting up a Simple Network  

This section will take users through a step-by-step guide to set up a simple pipe network 
including setting up objects used in the network. 
 

• At any point the Maximus help system can be viewed for the current dialog. Press F1 to 
view in a browser.  

• Set the units to be used for data entry. Although an overall unit set is defined each value 
can be entered in any units by using the local unit definition. For this example, we will set 
up in SI units, Home->Units and set to SI and press OK, Figure 4. 

 

Figure 4: Units set. 

• Next, we set the fluid type; options for fluid modelling are either Black Oil or 
Compositional. Ensure that Home->Compositional Fluid is selected as opposed to 
Black Oil. Use the down arrow to show the options.  



 Title:  Quick start guide CONFIDENTIAL Page 7 of 27 

   

 

 

 

Figure 5: Fluid selection via dropdown options. 

• Now we can start to build the model. Select the pipe object from the Insert tab as shown 
in Figure 6. Click on the model canvas to place the pipe object. Extend the pipe by drag 
and dropping one of the black squares at the end of the pipe object. If you want to move 
the pipe, drag-and-drop the black arrow in the middle of the pipe. The red circle indicates 
that the object is either not connected to another object or is missing data. 

 

 

Figure 6: Adding a pipe object to the model canvas. 

• Open the pipe object window by double clicking on the black arrow. In this window, it 
is possible to enter the parameters of the pipeline such as dimensions, models etc. 
Note: Some fields are pre-populated 

• To begin with, change the name of the pipe to Trunkline (each object must be 
uniquely named) by using the box at the top of the window. Note: Object names are 
not case sensitive, so PIPE is the same as pipe. 

• Set the internal diameter to 12" (use the drop-down menu to change the units from 
mm to inches) and the roughness to 0.05 mm. If you enter the value before changing 
the units, the value will change so it is the equivalent in the new units. To prevent this 
from happening, hold shift when selecting the units. It is also possible to use the pipe 
schedule button to add pipe properties from the Maximus database.  
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• The small square in the number field can be used to store comments about the data 
entered, Figure 7. This option can be disabled by un-checking the “Display 
comments button on input” option under Home -> General Settings -> GUI 
Settings. The models history and notable changes can also be recorded under 
Reports -> Revision History.  

 

Figure 7: Notes entry for data entry fields. 

• Copy the data from Table 1 (in the Excel file provided) and paste it into the profile 
table in the bottom right of the window.  After the data has been entered the window 
should look like Figure 8. Note: Actual pipeline profiles can easily be obtained by 
using the GIS view. 

 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

Table 1: Trunkline elevation profile and ambient conditions. 

Horizontal Distance (km) Elevation (m) Ambient Temperature (°C) 

0 0 5 

5 5 5 

10 -30 5 

15 10 5 

20 10 5 

25 0 5 

30 10 5 

35 7 5 

40 -11 5 

45 -20 5 

50 2 5 

55 -13 5 

60 -15 5 

65 -3 5 

70 -27 5 

75 -20 5 

80 8 5 

85 -9 5 

90 -17 5 

95 -2 5 

100 -26 5 
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Figure 8: Main trunkline settings 

• Click on Plot and the window shown in Figure 9 will appear. This is a graphical 
representation of the elevation of the trunkline over its length. The plot can be enlarged, 
modified, exported, or printed via the tabs and buttons. 

 
Figure 9: Trunkline elevation profile 

• Click on Close to return to the main pipe object window.  

• Click on the Heat Transfer tab. There are two options for calculating heat transfer where 

a U value can either be specified calculated based on the properties of the pipe, 

insulation materials and the pipe surroundings including burial, water etc. 

• We will not calculate the U value but specify it instead with a value of 4.5 W/m2/K 

(average ground value),  

 

• Figure 10. The U value is referenced to the pipe outer diameter, so does not include the 

pipe wall. So, the pipe wall thickness needs to be set, in this case 25 mm. 
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Figure 10: Heat transfer options. 

• We can ignore Estimates, Events and Models for this example, so click on the Flow 

Correlations tab. This page allows the user to select the correlations used to model the 

flow within the pipe. Leave the correlations to the default. Advantages and a description 

of each correlation can be found in the Maximus help files.  

Figure 11: Default flow correlations 

• Click on OK to save the changes and close the window. Note: Selecting Cancel on any 

top-level dialog will cancel all changes made in sub-dialogs. 

• Next a second pipe segment will be added. Add a new pipe to the model canvas and 

place it to the left of the trunkline. To attach the new pipe, drag and drop the right-hand 

black square to the left-hand black square of the trunkline. If they have connected 

correctly, a yellow circle should appear.  

• This yellow circle is a node and specifically a junction node. This junction is used to 

connect pipes together and may have more than two connections. It is assumed that no 

mass is produced or lost at a junction, i.e., the sum of the flowrate of the fluids that enter 

the junction is equal to the flow of the fluids that leave the junction.  

• The model should look like Figure 12.  
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Figure 12: Model with two pipes connected. 

• Open the new pipe and enter the following details:  

a. Name: Trunkline2. Note: object names can have spaces 

b. Internal diameter: 12"  

c. Pipeline profile as per Table 2.  

d. Roughness: .05 mm  

e. Overall heat transfer coefficient U: 4.5 W/m2/K  

f. Wall thickness: 25 mm 

g. Leave flow correlations to default. 

  

Horizontal 

Distance (km) 
Elevation (m) 

Ambient 

Temperature (°C) 

0 0 5 

5 20 5 

10 30 5 

15 10 5 

20 -10 5 

 

Table 2: Trunkline2 elevation profile and ambient conditions. 

 

• Now add three more pipes (Branch 1,2 & 3) so the model looks like 

 

 Figure 13: Network configuration. 

• For all three pipes, enter the following details:  

a. Rename the pipes so they match Error! Reference source not found..  

b. Internal diameter: 6"  

c. Pipeline profile as per Table 3.  

d. Roughness: 5×10-5 m  

e. Overall heat transfer coefficient U: 4.5 W/m2/K  
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f. Wall thickness: 25 mm 

g. Leave flow correlations to default.  

 

Horizontal 

Distance (m) 
Elevation (m) 

Ambient 

Temperature (°C) 

0 0 5 

50 10 5 

100 5 5 

150 -10 5 

Table 3: Branch elevation profile and ambient conditions. 

This concludes setting up the pipe network.  

4.0 Setting up sources and sinks  

Now the pipe network has been set up, it is now necessary to introduce fluids to the network 
at the inputs (the three branches) and remove fluids at the outputs (the end of the trunkline). 
This is achieved using sources and sinks.  
 
A source is a node object which is used to add fluids to the network. This is where the 
composition of the fluid is specified which can be achieved using the internal Maximus tool 
or by importing an Multiflash MFL file. There are also options to specify the fluid flowrate, 
pressure, and temperature. It is possible to have sources as junctions, i.e., in the middle of a 
pipe network.  
 
An example where this might be used is to add hydrate inhibitor or gas lift gas.  
 
A sink is a node object where fluids complete their journey through the pipe network. 
Similarly, to a source object, pressure and flowrates can be specified.  
Note, unlike process simulators, such as Petro-SIM® and HYSYS® which are specified from 
the inlet, Maximus can calculate backwards. For example, it is possible to specify a source 
flowrate and a sink pressure. In this case, Maximus will back calculate the source pressure 
to maintain the specified flowrate.  

To begin with, add a source object to the model canvas using the same method to add a 

pipe. The source object can be found on the Insert tab.  

 

Figure 14: The source object added to the model canvas. 

1. Open the source window by double clicking on the object. 

 

2. Under Source fluid, click on the dropdown menu starting with Launch Multiflash. 



 Title:  Quick start guide CONFIDENTIAL Page 13 of 27 

   

 

 

The three options, Figure 15, allowed to define a fluid composition are either: 

a. Launch Multiflash, using the Multiflash GUI,  

b. Load MFL file, loading a pre-created fluid file, or  

c. Advanced, using the legacy Maximus GUI functionalities. 

Figure 15: Fluid properties definition choice 

3. Select Load MFL File and browse for the Condensate.MFL file which was supplied with 

this guide. When the file is loaded, a pop-up confirms that the file was loaded 

successfully – click OK. 

 

4. Click on Properties to verify that the composition is loaded correctly. In the 

Composition tab, inspect the component list. In the Properties tab, select the 

appropriate Phase Boundaries and Calculate the phase diagram. 

Figure 16: Phase diagram 

5. Click OK on the Phase diagram and then the Properties window to close them. 
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6. Back in the Source window:  

a. Enter a temperature of 50°C.  

b. Under flowrate, change the dropdown to Stock Tank Gas and set the flowrate to 

10 mmscf/d.  

c. Tick the box next to the flowrate. When ticked this means that this parameter is 

specified for the model meaning the flowrate from this source will always be used.  

d. Leave the pressure and corresponding tick box blank. This will be calculated by 

Maximus. 

 

7. The source window should look like Figure 17. Click OK to close the window and save 

the changes.  

Figure 17: Complete source window 

8. Duplicate the source object by right clicking on it and select copy. Then right click on 

the canvas and select paste where you want to place the duplicated object. Repeat this 

so there is a third source, one for each branch.  

 

9. Drag and drop the ends of the three branches onto the relevant sources to connect 

them.  

Figure 18: Connected sources 
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10. Finally, a sink is required. Select a sink object from the Insert tab and place it onto the 

canvas. To make the model more visually appealing the sink object can be any of the 

sink type objects, i.e., sink, FPSO, Platform or LNG Plant: They all have the same data 

input requirements and functionality. 

 

11. Don’t forget to regularly save your model! 

 

Figure 19: Sink added to the model canvas. 

12. Open the sink and in the window, specify an arrival Pressure of 40 bara remembering to 

tick the box corresponding to pressure. Leave the sink temperature and flowrate blank 

as these will be calculated. Click OK to close the window and save the changes.  

 

13. At various points while setting up the network, red squares will have surrounded the 

objects. The red square means that there is an issue with the object such as information 

is missing, or the object needs to be connected to something. In Figure 19, there is a red 

square around the trunkline and the newly added sink. The trunkline square is because 

there is nothing connected to its outlet and the sink square is because it is not connected 

to anything.  

 

14. Attach the end of the trunkline to the sink and both red squares should disappear. If 

everything has been set up correctly there should be no red squares on the canvas and 

should look like Figure 16. 

 

Figure 20: The completed network with sources and sink. 
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5.0 Setting up and Running the Simulation  

Now the network is complete and fully specified, the properties of the simulation need to be 
set up. This section will demonstrate some of the settings available to the user.  

5.1 Snapshot and Life of Field  

As discussed earlier, there are two main types of simulation including Life of Field and 
Snapshot. In this example, snapshot will be used where a single steady-state timestep is 
used. Other specific operations can be selected and setup from the Insert menu. These 
include: 
 

Gas Lift Optimiser.  Optimise the production when a field has limited is gas lift 
gas for injection and/or has field constraints. 

Hydraulic Potential Controller 
 

FloWax Branch module 
 

Look Up table 
 

Well Stabiliser 
 

History Matching 
 

Tuning Tool 
 

6X Simulator 
 

UWA Hydrate Formation 
Utilise the UWA hydrate model  

 
To ensure the model is run in snapshot mode, click on the snapshot symbol on the Home 
tab, see Figure 21.  

 

 

Figure 21:  The snapshot mode button. 

5.2 General Settings  

General settings can be accessed by clicking on the Home tab and then General Settings. 
This allows various Maximus settings to be altered to suit the model/user.  
 
On the primary settings tab, change the tolerance from 0.01% to 0.002%. This will improve 
the accuracy of the results.  
 
As the simulation will be run as a snapshot, there is no need to change the life of field 
settings.  
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Figure 22: General settings window.  

5.3 Fluid Correlations and Models  

The fluid correlations and models window can be accessed by clicking on Home tab and 
then selecting Compositional Fluid.  
 
This window allows the user to specify the compositional models used in the simulation such 
as the thermodynamic model and the transport properties. When the MFL file was imported, 
these settings were overwritten to match the MFL file, therefore, there is no need to change 
any of the settings.  
 
Click on the phase diagram tab. This is where the thermodynamic limits of the model can 
be set. Restricting this window reduces the amount of computation required. The default 
maximum pressure is 1,000 bara. It is extremely unlikely that the model will reach this 
pressure so this can be reduced to 100 bar. Similarly, the temperature will not reach 1,000°C 
anywhere in the model so reduce this to 100°C.  
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Figure 23: Updated phase diagram limits. 

5.4 Running the model  

To run the model, click on the play symbol on the Home tab or in the title bar.  
 

 

Figure 24: The run button.  

If the model has been set up correctly the model should run without any errors and a 
message box like Figure 25 should appear. Click on OK to close the message box.  

Figure 25: Simulation Completed message. 

 

There should be messages in the dynamic solutions box like Figure 26. Any messages 
shown in red are severe errors and should be addressed. 

 



 Title:  Quick start guide CONFIDENTIAL Page 19 of 27 

   

 

 

 
Figure 26: Completed run. 
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6.0 Extracting results  

6.1 Nodes 

Now the model has been run it is possible to view the results of the simulation. The model 
has been set up so that the feed flowrates and temperatures have been set as well as the 
arrival pressure. This means a result of interest would be the calculated feed pressure. To 
see this, open the source object called Source and select the Results tab. 

Figure 27: Source results 

The pressure at this point to maintain an arrival pressure of 40 bar and a flowrate of 10 
MMscfd is about 58 bara. Under Junction Stock Tank Gas Flowrate, change the units to 
mmscf/d and the value should change to 10 which is what was specified.  
 
It is possible to add other results to this table by clicking on Customise.  
 
Next open the Sink and go to the results tab. The pressure is 40 bara as expected. To view 
the arrival temperature of the fluid, click on Customise. Select Junction Temperature in the 
pane on the left and click Add. Click on OK and message will appear. Click Yes. A new 
column will be added to the right of the existing results showing the temperature of 4.46°C.  

Figure 28: Customising results. 
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Figure 29: Sink results with temperature added. 

As expected, the total volume of gas through the sink is 30 mmscf/d given by the sum of the 
contribution of each source.  

6.2 Branches and profiles 

The results that have been looked at so far are node results meaning there is a single result 
at a specific point. Next, we will have a look at profile results which show multiple results, for 
example, over the length of a pipeline. Close the sink, open the trunkline window, and go to 
the results tab. It will look similar to the source and sink results page; however, it will show 
single results for the inlet and outlet of the pipeline and there is the ability to plot profiles.  
Locate and tick the tick box under Profile and then click Plot Profiles.   

Figure 30: Trunkline results window. 

A window will appear showing the default profile results which are temperature and pressure 
over the pipeline.   
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Figure 31: Trunkline temperature and pressure profile. 

The raw data can be viewed by clicking on the Data tab. This data can also be copied and 
pasted for use in other programs such as spreadsheets.  
 
It is possible to change the data represented in the profile chart. We will substitute 
temperature with liquid holdup. First, select the Series tab. The column called Shown is used 
to select which data series are included. Untick temperature and tick liquid holdup. The next 
column, Axis, is used to choose which axis will be used to represent the selected data. For 
liquid holdup, ensure right is selected. There are also further options to change how the data 
is represented such as it is possible to change to a stacked chart. Return to the Plot tab and 
the chart should look like Figure 28.  

Figure 32: Chart data series selection 

 



 Title:  Quick start guide CONFIDENTIAL Page 23 of 27 

   

 

 

.  

Figure 33: Trunkline profile with pressure and liquid holdup. 

In the results tab, by clicking the “View” button in the Composition column in Figure 30, next 
to the profile checkbox, it is possible to visualise the composition of the fluid at the sink and 
its properties. By right clicking the View button, the phase diagram is automatically 
computed. In this case, the composition would be identical to the one at the sources, since 
the three sources were all created by uploading the same .mfl file. This is not necessarily 
going to be the same however, in case of fluids with different composition in each source. 

7.0 Events Configurator 

An event can be connected to any object within the model and consists of 3 elements: 

- If (the condention is meet) 

- Then set (a particular variable)  

- To (a numerical value or status) 

The event configurator allows the setting up of the “If” condition for complex events via a 
dedicated dialogue. It can be turn on or off globally via the option Use Event Configurator 
under Home->General Settings.  
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Figure 34: General Setup 

And activated or deactivated locally on the events dialog as in Figure 35 

Figure 35: Events Setup 

Once selected the Add event will activate the events configurator as in Figure 36 

 

Figure 36: Events Configurator (initial screen) 

The recommend workflow is: 

• Select the number of levels required (default is 1) 

• Select New from Figure 36 and the dialog changes to Figure 37 with 1 new level  
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Figure 37: Events Configurator (after New) 

• Use of and/or conditions can be specified 

Figure 38 shows the use of: 

- Multiple conditions 

- Tree View 

- Model variables will in the list (this is from Exercise 13) 

 

Figure 38: Typical usage 
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8.0 Shortcuts 

Useful shortcuts: 

Where Action Result 

Any spreadsheet  CTRL + mouse wheel  Zoom in and out 

Unit description CTRL + change units Numbers do not get converted 

Canvas Mouse wheel Zoom in and out 

Canvas Press and hold mouse wheel  Pan model  

Canvas Shift Move multiple objects 

Anywhere Press F1 key Brings up help on that dialog 

About menu About - > Web Portal Brings up latest information on a Wiki 
page 

About menu  About - > About Maximus Licensed Features 

Canvas Drag-and-drop a file from 
Windows Explorer 

Files loaded 
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9.0 Menu structure 

File Home Insert View Reports Tools 
New Cut/Copy/Paste Source GIS map Solution messages Excel Add-in 

Open-> Delete/Undo Delete Junction Switch to classis Phase Diagram Batch run 

Open Example  General  Sink Switch Window Revision history Licences 

Save Units Reservoir Zoom/Find Plots Open Interface 

Save As Compositional or 
Black Oil Fluid 

Completion Icon view Reporting options Web Portal 

Export Model variables Tubing Toggle Options Historian  

Print-> Events Pipe Full messages Check Meter  

Close Model Flow correlations Riser Specifications   

Exit Snapshot Separators Runtime displays   

 Life of Field Field Equipment Plotter control   

 Sensitivity Analysis Connector Templates   

 Reservoir Tables Chokes    

 Initialisation Heater/Cooler    

 Start/Abort Wizard    

 Restart Operations    

 Pointer/unselect Utilities    

 Active/inactive     

 

Trademark/Registered Trademark Reference 

® Maximus is a trademark of KBC Advanced Technologies Limited and is registered in various territories. 
® Multiflash is a trademark of KBC Advanced Technologies Limited and is registered in various territories. 
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